Jump to content
Register Now

Bug going around causing issues with Xbox app not loading on PC

Recommended Posts

Has anyone been dealing with this? I recently deleted a bunch of games to make room for a game from gamepass. I went to download the game and it encountered an error where it wouldn't download, but it kept saying download. I made sure to cancel in the EA app and it seemed to be fine, but the Xbox App was bricked up and wouldn't let me download the game. So I closed out of the Xbox app and reloaded it, this time it gets stuck at the Xbox logo. I tried just about everything; Deleted app, reinstalled, moved it do a different drive and did other steps, nothing. And then I decided to check the reviews for the app and a lot of the reviews are saying they are having similar issues. Here I thought this was just an issue with my PC and I was getting worried I'd have to re-install windows to get Xbox to work again. Thankfully I found the fix in the reviews, and I figured I'd share it here if anyone is dealing with the same issue, as it seems to be affecting a lot of people after the recent update. 

This was the review that solved the issue: 


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...