Jump to content
Register Now
The Blackangel

Stripped screws

Recommended Posts

I need to open up my Switch, because the R1 button sticks really bad so I need to clean it up. The problem I'm having is that some of the screws are completely stripped. I've watched videos that supposedly work, but I haven't had any luck. One was to press down with a rubber band between the screw and screwdriver. Another was to put a bit of superglue on the tip of the screwdriver and to hold is firmly against the screw. Neither of those worked for me. I don't want to snap the shell of this thing, but I need to open it to clean it. I spent a good amount of money for the right screwdrivers to so this, and now the screws are giving me a big "fuck you".

Anyone have any ideas?

Link to comment
Share on other sites

There can be few things more annoying than stripped screws, they really are a pet hate of mine. Why do these manufacturers make them out of such soft metal?


Anyway, I do work in engineering so have dealt with this sort of thing a lot. Given what you have already tried (And I must say, I think somebody's taking the piss with superglue thing, that was never going to work.), outside of  drilling through the screw, I can think of only two things that likely to work.

  1. Gripping the screwhead in a set of pliers and trying to turn it that way.
  2. Using impact force to turn the screw. I've done this . with rusted and rounded nuts and bolts, but the principle is essentially the same.


What you'll need is a screwdriver (Flat head, preferably) or small chisel and a hammer.




I hope that helps. Let me know if you enjoy any luck with this.

Link to comment
Share on other sites

21 hours ago, Shagger said:

Gripping the screwhead in a set of pliers and trying to turn it that way.

The screws in the Switch are down in the shell beyond where pliers could ever reach. Also they're Y screws. If they were phillips screws or flat screws, things would be much easier. Hell, even hex screws would be better. But it's that damn Y shit that seriously drives me insane. I'll try the thing you posted. Hopefully it will do the trick. Anyway, here's a pic of the bullshit I'm dealing with.




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...